Legacy Versions

Older versions of the HPE CSI Driver for Kubernetes are kept here for reference. Check the CSI driver GitHub repo for the appropriate YAML files to declare on the cluster for the respective version of Kubernetes.

Kubernetes 1.17

kubectl apply -f https://raw.githubusercontent.com/hpe-storage/co-deployments/master/yaml/csi-driver/v1.4.0/hpe-csi-k8s-1.17.yaml

Note

Latest supported CSI driver version is 1.4.0 for Kubernetes 1.17.

Kubernetes 1.16

Note

Latest supported CSI driver version is 1.3.0 for Kubernetes 1.16.

Kubernetes 1.15

Note

Latest supported CSI driver version is 1.3.0 for Kubernetes 1.15.

Kubernetes 1.14

Note

Latest supported CSI driver version is 1.2.0 for Kubernetes 1.14.

Kubernetes 1.13

Note

Latest supported CSI driver version is 1.1.0 for Kubernetes 1.13.